Work Around for .NET Framework 4.7 or a later update is already installed on this computer

categories: [ Visual Studio ] tags: [ dotnet ] [ Visual Studio ]
created: 07 Dec 2017 @ 14:48 modified: 07 Dec 2017 @ 14:48

I see this message most times I format my machines after opening existing projects in Visual Studio and I always forgot how I solve it

image

You may think well that's simple right, install .net 4.7... the only problem then is you get this message which might be why you came to this post Smile

image

The reason for this is that you need to install the Dev Pack for .net 4.7. In my case I already installed .net 4.7.1 and so just installed 4.7 didn't work for me. https://www.microsoft.com/net/download/windows 

image

Hope this helps someone else and also future me if you reading this you owe me a beer Open-mouthed smile.